Linux *BETA* Demo

Linux support forum for Eschalon: Book I

Linux *BETA* Demo

Postby BasiliskWrangler » Sun Dec 09, 2007 11:43 am

Okay, here is a link to the BETA demo for the Linux version of Eschalon: Book I.

Most important! Some people (including myself) have discovered that having Compiz/Beryl active can cause some gameplay glitches. I am recommending people disable glitzy desktop effects, especially if you are experiencing problems. Note that some people claim the demo runs perfectly with Compiz, so let us know what you find.

Known Issues:
- The Help button on the launcher doesn't do anything.
- Some ATI hardware may run the game with small graphic artifacts such as seams between the tiles. This is a driver issue. Always ensure you are running the latest drivers for your ATI hardware.

Dependencies:
libstdc++.so.5

http://www.gamershell.com/download_22401.shtml
Last edited by BasiliskWrangler on Mon Dec 17, 2007 11:44 pm, edited 17 times in total.
User avatar
BasiliskWrangler
Site Admin
 
Posts: 3568
Joined: Thu Jul 06, 2006 10:31 am
Location: The Basilisk's Lair

Postby MaxEd » Sun Dec 09, 2007 1:07 pm

First try - Debian Linux 4.0 running on VmWare. Game depends on libstdc++.so.5, but most modern Linux distributions only have version 6 by default as far as I understand. It's easy to obtain it, but it should be somewhere in documentation, I think... Or you may try to compile with static library, but this will greatly increase executable size.
MaxEd
Initiate
 
Posts: 11
Joined: Mon Nov 19, 2007 12:26 pm
Location: Moscow, Russia

Postby Per » Sun Dec 09, 2007 2:50 pm

It seems to work fine in Arch Linux 64-bit with 32-bit libs installed. I haven't had time to test it so much yet, but it starts at least. I'll check back later when I've had the time to test it more thoroughly.

Edit: I noticed that the save files and config file is in a directory called eschalon_b1_saved_games in the users home folder. In my opinion you should follow the standard linux way of storing user specific application data and create a hidden folder, for example .eschalon, where you store these files. That way you don't clutter up the users home folder.
Last edited by Per on Sun Dec 09, 2007 3:59 pm, edited 1 time in total.
Per
Apprentice
 
Posts: 22
Joined: Mon Nov 19, 2007 10:07 am
Location: Sweden

Postby kxc » Sun Dec 09, 2007 3:33 pm

Work fine under Ubuntu 7.04. Just one problem: tile boundaries are visible as if there are tiny gaps between the tiles.
kxc
Initiate
 
Posts: 11
Joined: Wed Dec 05, 2007 6:24 am

Postby BasiliskWrangler » Sun Dec 09, 2007 3:58 pm

kxc: Hmm, I don't see any gaps in the tiles on my machine. I'm sure that is a video driver issue on your machine.

The biggest play issues I've personally noticed is that it seems really slow, at least on Ubuntu 7.10. My test machine is well within what should be the minimum specs and it is too slow for me to enjoy, even with 16-bit color enabled. I'm going to try some different video drivers.

Has anyone else confirmed that the two issues I reported (no help, game hangs when clicking purchase button) are working (or not) on other distros?
User avatar
BasiliskWrangler
Site Admin
 
Posts: 3568
Joined: Thu Jul 06, 2006 10:31 am
Location: The Basilisk's Lair

Postby kxc » Sun Dec 09, 2007 4:18 pm

BasiliskWrangler wrote:The biggest play issues I've personally noticed is that it seems really slow, at least on Ubuntu 7.10. My test machine is well within what should be the minimum specs and it is too slow for me to enjoy, even with 16-bit color enabled. I'm going to try some different video drivers.


I checked again and have noticed the same thing. Do you use an ATI video card?
kxc
Initiate
 
Posts: 11
Joined: Wed Dec 05, 2007 6:24 am

Postby Per » Sun Dec 09, 2007 5:14 pm

It does not seem slow at all for me. In the options menu it rates my computer between 1 and 2. I use 32 bit color in fullscreen, with an E6600 cpu (Core2Duo 2.4GHz) and Nvidia 8800GTS videocard. I'm going to try it on my laptop soon too, that uses an integrated Intel X3100 videocard.

As for the other issues (no help, game hangs on purchase), I've noticed that when clicking the help button it only prints out that I should refer to the help.html file. No big deal, though a popup would be nice (or even actually opening the help file ;) ).

When clicking on the purchase button the first time the game crashed, and I had to kill it. When I tried a second time just to confirm, it actually opened firefox and went to the purchase page. I haven't been able to make it crash since then.

I've been playing for a while now, and so far it seems pretty stable. No crashes so far (exept the purchase thingy), and I haven't noticed any graphical or game bugs.

Edit: Now I've tested the game on my laptop too, with a T7100 cpu (Core2Duo 1.8Ghz) and X3100 integrated graphics. It was playable, but noticeably slower than on my other computer. The graphic card is not a very good one though. But the game rated my laptop between 0 and 1 oddly enough :shock: The graphics also looked quite bad, since they became blurry and stretched when running fullscreen on a 1440x900 screen.
Per
Apprentice
 
Posts: 22
Joined: Mon Nov 19, 2007 10:07 am
Location: Sweden

Postby BasiliskWrangler » Sun Dec 09, 2007 8:00 pm

Per: Yes, I encourage people to set their video to "Maintain Aspect Ratio" so the game doesn't stretch out when played widescreen, but I guess some people prefer it that way.

kxc: I did have an ATI, but I could not get it to run worth crap so I put in an older GeForce card (4 series) instead. It's better than the ATI, but still running so slow for me.
User avatar
BasiliskWrangler
Site Admin
 
Posts: 3568
Joined: Thu Jul 06, 2006 10:31 am
Location: The Basilisk's Lair

Postby kxc » Sun Dec 09, 2007 8:19 pm

3d applications(or 2d applications that use opengl for rendering) generally run very slow on linux systems with ATI video cards. At least it was the case 2 years ago. Apparently, same problem still remains. Can you use another rendering option? SDL surface maybe?
kxc
Initiate
 
Posts: 11
Joined: Wed Dec 05, 2007 6:24 am

Postby PhilosophiX » Mon Dec 10, 2007 2:11 am

The Demo runs, but no sound and it runs very slow in comparison to the windows version. I'm using openSuse 10.2

I couldn't find any information about why the sound isn't running. I ran it from the command line to see if it would leave any messages but nothing... I closed down the usual culprits as well (namely Amarok).

Still, it does run and that's a good start! Well done!

Good luck getting the Linux version to work. I will be here to help you in anyway I can. I'm a Linux noob but I appreciate the effort you are taking to make it available.
What is a man, If his chief good and market of his time Be but to sleep and feed? a beast, no more. Sure, he that made us with such large discourse, Looking before and after, gave us not that capability and god-like reason to fust in us unused.
User avatar
PhilosophiX
Marshall
 
Posts: 144
Joined: Sun Sep 16, 2007 4:13 am

Postby PhilosophiX » Mon Dec 10, 2007 2:33 am

*Update*
I closed Firefox (and the 165 tabs I had open) and that fixed the sound. It runs slightly faster now, but it's still sluggish (by sluggish I mean unplayable sluggish).

So we're getting there. I'll play about with closing things down at this end to see if there's anything running that might be slowing it down, just in case. But all major applications are now closed so I'm not sure how I can milk it. Now seems like a good time to get shot of Kerry F***ing Beagle. I hate that damn thing, and it won't go quietly.

Anyway, congrats once again, your efforts are appreciated.

*Update II*
Strangely enough, sound doesn't work again, and yet there is nothing open except the stuff that normally runs in the background and nothing that actually uses the sound.

Performance rating is 35 (compared with 10-18 on windows).

Wish I could be of more help.
What is a man, If his chief good and market of his time Be but to sleep and feed? a beast, no more. Sure, he that made us with such large discourse, Looking before and after, gave us not that capability and god-like reason to fust in us unused.
User avatar
PhilosophiX
Marshall
 
Posts: 144
Joined: Sun Sep 16, 2007 4:13 am

Postby PhilosophiX » Mon Dec 10, 2007 2:57 am

Okay, Sound sometimes works... So I can get sound if I close and reopen the game until it makes that noise... (thank god you gave the launch menu sound or I would never know).

*Update III*

I switched off all my virtual desktops and limited myself to only 2 but it doesn't make any difference.

Outside 25-35 sometimes as high as 45. Performance rating and dungeons is consistently 23-27. Dungeons are playable, outside is a crawl.

Inside the dungeon the walls have lines where they join up, that wasn't visible in the windows version.

I wish I could be more help. I'll check back here regularly.
What is a man, If his chief good and market of his time Be but to sleep and feed? a beast, no more. Sure, he that made us with such large discourse, Looking before and after, gave us not that capability and god-like reason to fust in us unused.
User avatar
PhilosophiX
Marshall
 
Posts: 144
Joined: Sun Sep 16, 2007 4:13 am

Postby Per » Mon Dec 10, 2007 5:10 am

PhilosophiX (and everyone else who have performance problems), perhaps you should tell us what your hardware is, to see if there's something common that might be the cause. As I said it's running really smooth for me, but I have an Nvidia card. ATI has historically had really crappy drivers, but from what I know they should be better now.

Something to try would be to turn off compiz/beryl (those shiny 3d effects) if you have that on, since it doesn't seem to play nicely all the time with other OpenGL applications.

As for the sound the game doesn't seem to be using ALSA, but rather OSS. I don't have any proof of this, but it behaves like it's using OSS. It doesn't care about some mixer settings, which means that the sound control doesn't work, and it also doesn't like to share the sound so that you have to turn off any program that plays sounds. So if it's possible it would be a lot better to use ALSA instead, since OSS is deprecated.

Edit: PhilosophiX, check this out if you haven't already: http://en.opensuse.org/Disabling_Beagle ;)
Last edited by Per on Mon Dec 10, 2007 5:32 am, edited 1 time in total.
Per
Apprentice
 
Posts: 22
Joined: Mon Nov 19, 2007 10:07 am
Location: Sweden

Postby Altefcat » Mon Dec 10, 2007 5:18 am

The game is running perfectly on my Ubuntu box 8).

It's a Dell Latitude D620, with intel integrated graphics, and Ubuntu Feisty Fawn is running on it.

Thanks for the demo BasiliskWrangler !

Edit : Window mode is fine, but if I try fullscreen I get this error :
Code: Select all
appstub.linux signal handler 11X Error of failed request:  GLXBadDrawable
  Major opcode of failed request:  159 (GLX)
  Minor opcode of failed request:  11 (X_GLXSwapBuffers)
  Serial number of failed request:  4862
  Current serial number in output stream:  4864


If I activate Compiz, windows have no decoration.
Altefcat
Initiate
 
Posts: 10
Joined: Tue Nov 20, 2007 7:02 am

Postby PhilosophiX » Mon Dec 10, 2007 6:25 am

Thanks Per. Beagle eradicated. I don't use Compiz/Beryl, namely because my Intel Integrated Graphics doesn't really do much with it. I'm on a Twinhead, Durabook, 1.6GHz, 1GB Ram, Intel Integrated Graphics with 256MB of memory (shared). Next time I'll be buying something with a little more oomph...
What is a man, If his chief good and market of his time Be but to sleep and feed? a beast, no more. Sure, he that made us with such large discourse, Looking before and after, gave us not that capability and god-like reason to fust in us unused.
User avatar
PhilosophiX
Marshall
 
Posts: 144
Joined: Sun Sep 16, 2007 4:13 am

Next

Return to Eschalon: Book I Support [Linux]

Who is online

Users browsing this forum: No registered users and 0 guests